收藏
回答

初始化取不到data中变量的值

问题模块 框架类型 问题类型 操作系统 工具版本
开发者工具 小程序 Bug Windows 1.02.1907160

我使用 js 中的data 赋值 ,然后页面进行渲染  出现取不到值的问题,但是没有报错.这是为什么?

这是js中data中赋的值


selectvalue: ['t1', 't2'],

这里是wxml中的运用(部分效果没有给出,太多了wxss)



<view>当前选中的滚动框的值:{{changeValue}}</view>

<view class="cu-modal bottom-modal {{modalName=='bottomModal'?'show':''}}">

<view class="cu-dialog">

<view class="cu-bar bg-white">

<view class='action text-green' bindtap='hideModal' style='font-size:32rpx;padding-left:20rpx;'>取消</view>

<view class='action' style='font-size:32rpx;padding-left:20rpx;'>值对应名称</view>

<view class='action text-blue' bindtap='confirmEnterprise' style='font-size:32rpx;'>确定</view>

</view>

<picker-view indicator-style="height: 50px;" style="width: 100%; height: 200px;" bindchange="changeview">

<picker-view-column>

<view wx:for="{{selectvalue}}" style="line-height: 50px" >{{item}}</view>

</picker-view-column>

</picker-view>

</view>

</view>

<view>


最后一次编辑于  08-06  (未经腾讯允许,不得转载)
邀请回答
复制链接收藏投诉关注问题回答

14 个回答

  • 明年今日
    明年今日
    08-06



    这样可以出来啊,你再控制台里面打开选中,检查一下样式吧。是不是设置了float什么的。

    08-06
    赞同
    回复 2
    • bibolibo
      bibolibo
      08-06
      这个是其他人写的一个模板,原本用的时候也是可以的,但是跟新版本之后就不行了,
      08-06
      赞同
      回复
    • bibolibo
      bibolibo
      08-06回复bibolibo
      其余的同样的代码,仍然可以使用,就只有这一个选择出了问题.(整个页面也是) 其他的没问题.这才比较疑惑
      08-06
      赞同
      回复
  • bibolibo
    bibolibo
    08-06

    控制台打出为undefined

    08-06
    赞同
    回复 9
    • 明年今日
      明年今日
      08-06
      有demo链接么?做个demo,生成 链接传上来看看
      08-06
      赞同
      回复
    • bibolibo
      bibolibo
      08-06
      这个是用的测试号写的..我弄一下,看可不可以.
      08-06
      赞同
      回复
    • bibolibo
      bibolibo
      08-06回复明年今日
      我用代码片段可以输出,我检查一下是不是小程序页面的问题..谢谢
      08-06
      赞同
      回复
    • 明年今日
      明年今日
      08-06
      是不是跟picker-view这个有关系,你把你的{{item}}这行代码放出来试试,如果可以,就是那个pick组件的问题了
      08-06
      赞同
      回复
    • 明年今日
      明年今日
      08-06回复bibolibo
      不客气
      08-06
      赞同 11
      回复
    查看更多(4)