收藏
回答

关于getUserInfo的兼容问题

问题模块 框架类型 问题类型 API/组件名称 终端类型 微信版本 基础库版本
API和组件 小游戏 Bug getUserInfo 工具 1.9.4

小游戏中创建登录按钮接口要求做2.0.1基础库的支持,低版本需要兼容处理

UserInfoButton wx.createUserInfoButton(Object object)

基础库 2.0.1 开始支持,低版本需做兼容处理

创建用户信息按钮


现在我的处理方式是,2.0.1版本及以上,调用

wx.createUserInfoButton

创建按钮,2.0.1一下版本,在页面内创建按钮,并在点击事件中通过getUserInfo获取用户信息,

在2.0.1以下版本获取用户信息报错:


    getUserInfo:fail scope unauthorized

最后一次编辑于  2018-05-11
回答关注问题邀请回答
收藏

4 个回答

  • 人云亦云
    人云亦云
    2018-05-23

    请问 fix 是什么意思?

    2018-05-23
    赞同
    回复
  • 梁马勇
    梁马勇
    2018-05-11

    刚才又试了一下,已经好了,Fix掉了

    2018-05-11
    赞同
    回复
  • 梁马勇
    梁马勇
    2018-05-11

    是不是不用做2.0.1以下基础库版本的兼容了?

    2018-05-11
    赞同
    回复
  • 梁马勇
    梁马勇
    2018-05-11

    怎么解决?

    2018-05-11
    赞同
    回复