收藏
回答

请教关于emoji变成四个问号的问题?

mysql数据库

我把字符集改成utf8mb4,emoJi就变成四个问号了,请问是哪里的配置问题吗?


我负责维护一个性教育微信群的专题信息,要把群里的专题录入到系统中,但是在处理带有emoji的内容时,emoji就变成四个问号?请问这该怎么解决?


文字原文带emoji表情




录入之后就变成四个????




数据库中只改了具体表格的字段字符集和该表的字符集为 utf8mb4


最后一次编辑于  2019-12-09
回答关注问题邀请回答
收藏

6 个回答

  • Stephen
    Stephen
    2019-12-09

    检查数据库的编码是不是utf8mb4,感觉像是只设置了单个字段,数据库还是utf8

    2019-12-09
    赞同 1
    回复
  • 这都申请了
    这都申请了
    2019-12-09

    1、my.ini的字符编码设置

    2、数据库、表、字段的字符编码设置

    3、mysql连接字符串的字符编码设置

    2019-12-09
    赞同 1
    回复
  • 。
    2019-12-09

    好像得base64  加密解密

    2019-12-09
    赞同 1
    回复
  • 祺爸💎
    祺爸💎
    2019-12-09
    录入读取的时候连数据库的字符编码是什么?
    2019-12-09
    赞同 1
    回复 2
    • 小肥羊
      小肥羊
      2019-12-09
      utf8,难道这里也要改成utf8mb4吗,真的太感谢了。
      2019-12-09
      回复
    • 小肥羊
      小肥羊
      2019-12-09回复小肥羊
      感谢,数据库连接字符集charset改晨utf8mb4,已亲测成功,再次感谢各位。
      2019-12-09
      回复
  • 小肥羊
    小肥羊
    2019-12-09

    感谢各位解答,数据库连接字符集charset改晨utf8mb4,已亲测成功,再次感谢各位


    <?php
     
     
     
    return [
     
        'class' => 'yii\db\Connection',
     
        'dsn' => 'mysql:host=localhost;dbname=easywechat',
     
        'username' => 'root',
     
        'password' => 'root',
     
        'charset' => 'utf8mb4',
     
     
     
        // Schema cache options (for production environment)
     
        //'enableSchemaCache' => true,
     
        //'schemaCacheDuration' => 60,
     
        //'schemaCache' => 'cache',
     
    ];



    2019-12-09
    赞同
    回复
  • 鲤子
    鲤子
    2019-12-09
    https://www.baidu.com
    2019-12-09
    赞同
    回复
登录 后发表内容
问题标签