收藏
回答

小程序组件版本兼容问题

问题模块 框架类型 问题类型 API/组件名称 终端类型 微信版本 基础库版本
API和组件 小程序 Bug 自定义组件 工具 6.6.5 1.6.3

如图,微信小程序官方开发文档说明,组件的支持需要基础库1.6.3或更高版本


点击在开发者工具中预览效果


将开发者工具的调试基础库修改版本为1.6.3,开发者工具报错,如图:



最后一次编辑于  2018-07-02  (未经腾讯允许,不得转载)
邀请回答
复制链接收藏投诉关注问题回答

7 个回答

  • L
    L
    2018-07-02

    并未在真机上调试过(真机我们已经找不到这么低的版本了,但是我们还是有一些重要用户是基础库1.6.4版本,所以我们要求最低基础库版本是1.6.3),我只是在最新版微信开发者工具进行的调试出错的。系统是windows,开发者工具版本是1.02.1806120。

    另外还想请您们帮忙确定一下,这个问题只是在开发者工具上有,还是发布到正式版,也会出现同样的问题?

    2018-07-02
    赞同
    回复 1
    • LastLeaf
      LastLeaf
      2018-07-03

      感谢反馈,这是个已知问题,属于开发者工具对旧版本基础库的模拟有误。


      微信客户端的基础库极少停留在1.6.3这样的版本上,绝大多数情况下应该自动升级到1.6.8了,不必过于担心。

      2018-07-03
      赞同 11
      回复
  • 土豆豆
    土豆豆
    2018-07-03

    都已经说了最低支持是1.6.4开始的,1.6.3当然用不了啊,当然会报错啊,当然不只是在开发工具,当然在正式版也会啊

    2018-07-03
    赞同
    回复 1
    • L
      L
      2018-07-03

      官方文档明确说明:“所有自定义组件相关特性都需要基础库版本 1.6.3 或更高。”

      我的理解是1.6.3是支持的。另外,官方给的代码片段 wechatide://minicode/OMfVAKmZ6KZT ,我将基础版本切换为1.6.4,同样会报错。如图:


      2018-07-03
      赞同
      回复
  • Can🌴
    Can🌴
    2018-07-03

    用 1.6.4 就好了

    2018-07-03
    赞同
    回复 1
    • L
      L
      2018-07-03

      我在开发者工具里,将基础库版本修改为1.6.4同样会报错。

      然后我理解的是,只是在开发者工具会出现报错,在正式版上是不会出现报错的,对吗?

      2018-07-03
      赞同
      回复
  • Freddy马战
    Freddy马战
    2018-07-04


    2018-07-04
    赞同
    回复