收藏
回答

navigator组件小程序跳小程序兼容性问题

问题模块 框架类型 问题类型 API/组件名称 终端类型 微信版本 基础库版本
API和组件 小程序 需求 navigator 客户端 6.6.7 2.0.7


这个接口现在替换成了 navigator 组件,但是 navigator 文档上给出的版本说明是2.0.7才支持。请问低于2.0.7的版本也兼容么?


如果说低于2.0.7也兼容,那 navigator 跳转小程序的最低兼容版本到底是多少,请官方人员及时更新文档,并标注出来。


我们考虑兼容性做了如下处理:

2.0.7+ 使用navigator

2.0.7- 通过api跳转

如果api废弃,是否影响2.0.7以下的版本。希望有详细的说明

最后一次编辑于  2018-08-31  (未经腾讯允许,不得转载)
邀请回答
复制链接收藏关注问题回答

4 个回答

  • 凌云摘星傲苍穹
    凌云摘星傲苍穹
    2018-08-31

    2.0.7 就是 navigator 跳转小程序的最低兼容版本。

    2018-08-31
    赞同
    回复 3
    • #.o0OfF
      #.o0OfF
      2018-08-31

      为帮助用户获得沉浸式的小程序浏览体验,现提供“打开其他小程序”组件,用户点击后可以跳转至其他小程序。7月5日起,新发布的小程序版本,将不再支持无需用户点击即可直接调用的“打开其他小程序”接口,最新版开发者工具已经提前取消了该接口支持,请开发者尽早适配。


      意思是说7.5号开始低版本 api 打开小程序也取消支持这个接口了是么。


      2018-08-31
      赞同
      回复
    • 凌云摘星傲苍穹
      凌云摘星傲苍穹
      2018-08-31回复#.o0OfF

      接口现在还没有取消,具体取消的时间可以等一下后续的通知,会保证兼容的

      2018-08-31
      赞同
      回复
    • #.o0OfF
      #.o0OfF
      2018-08-31回复凌云摘星傲苍穹

      ok,thanks

      2018-08-31
      赞同
      回复