收藏
回答

wx.requestSubscribeMessage调用失败?错误码:10001

调用wx.requestSubscribeMessage时,填写一个id,调用成功

代码:

wx.requestSubscribeMessage({
                tmplIds: ['aIVC0gU-7vDggTrC5zpSK-k5QJT_pthkQiCFd23kTFQ'],
                success(res) {
                    console.log(res);
                    if (callback) {
                        callback(res);
                    }
                },
                fail(res) {
                    console.log(res);
                },
                complete(res) {
                    console.log(res)
                }
            })

返回如下:


调用两个id时会提示以下错误

代码:

wx.requestSubscribeMessage({
                tmplIds: ['aIVC0gU-7vDggTrC5zpSK-k5QJT_pthkQiCFd23kTFQ','6GLQL6UbQFDqwf9_gijnWxVJb_rszOc5yWUrjL9Ii2o'],
                success(res) {
                    console.log(res);
                    if (callback) {
                        callback(res);
                    }
                },
                fail(res) {
                    console.log(res);
                },
                complete(res) {
                    console.log(res)
                }
            })

错误如下:


最后一次编辑于  12-04
回答关注问题邀请回答
收藏

4 个回答

  • 社区技术运营专员-灵芝
    社区技术运营专员-灵芝
    12-04

    开发工具么?基础库版本是2.9.4?请切换一下基础库再试试

    12-04
    赞同
    回复 10
    • 健哥
      健哥
      12-05
      出现一样的报错问题,基础库版本2.9.4,跟上图一样错误码10001,切换到2.9.3,配置的两个推送在开发者工具上只显示了一个,success回调也只有对其中一个订阅状态的回调,切换到2.9.2,就直接提示开发者工具不支持此api,发布到线上后,发现配置的两个消息推送也只出现了一个
      12-05
      回复
    • 社区技术运营专员-灵芝
      社区技术运营专员-灵芝
      12-05回复健哥
      基础库2.9.4下出现报错是已知问题;基础库2.9.3下可以打印wx.getSystemInfo与下图对照一下微信版本;基础库2.9.2版本已明确提示原因,请知悉
      12-05
      回复
    • 健哥
      健哥
      12-05回复社区技术运营专员-灵芝
      老铁,我手机微信版本是7.0.9的哦,华为V30,开发版是可以订阅两个信息,但是发布到线上了就只能弹一个订阅消息,算了先不纠结了,这个订阅消息对我们产品现在意义不大,等你们完善好了我再接,加油
      12-05
      回复
    • 社区技术运营专员-灵芝
      社区技术运营专员-灵芝
      12-05回复健哥
      上述所说皆是在开发工具的基础上的哈,真机应该是没有该问题的
      12-05
      回复
    • Mr.D
      Mr.D
      12-05回复健哥
      和你一样的遭遇,有解决的没?
      12-05
      回复
    查看更多(5)
  • moon pie
    moon pie
    12-04

    有没有官方来回答下 是什么原因

    12-04
    赞同 2
    回复
  • 晓程序观察员
    晓程序观察员
    星期二 09:06

    这个问题和手机的版本没有关系吧。现在是使用开发者工具在调试,基础库也是2.9.4.

    星期二 09:06
    赞同
    回复
  •  
     
    12-06

    老铁,我的手机也是安卓版本也是8.0以上的,在填写两个模板id下,在手机预览的时候也是出现只有一个id消息的情况

    12-06
    赞同
    回复
问题标签