收藏
回答

模版小程序跳转到另外的小程序异常

框架类型 问题类型 终端类型 微信版本 基础库版本
小程序 Bug 客户端 6.6.7 2.2.2

- 描述 同样的代码,单独提交为体验版本后,可以正常跳转。但是如果设置成模板项目后,则跳转失败!代码如下


组件:

<navigator
    target="miniProgram"
    app-id="wx3cfa30beb2d5757x"
    path="pages/cards/main"
    version="trial"
    class="auth-btn"
    bindsuccess="bindsuccess"
    bindfail="bindfail"
    data-title="跳转去了快推小程序">
    确认
</navigator>


app.json:

{
    "navigateToMiniProgramAppIdList": [
        "wx3cfa30beb2d5757x"
    ]
}


- 当前 Bug 的表现




- 预期表现 可以正常跳转


- 复现路径


- 提供一个最简复现 Demo


最后一次编辑于  2018-11-03
回答关注问题邀请回答
收藏

4 个回答

  • 林杰锋
    林杰锋
    2018-11-10

    已经用了2.4.0还是有部分不能正常跳转,有这个问题吗?

    2018-11-10
    有用
    回复
  • liya零夜
    liya零夜
    2018-11-05

    2.4.0基础库还没有发布。

    2018-11-05
    有用
    回复 2
    • 大叔·杨
      大叔·杨
      2018-11-05

      就是调试工具中的 "基础调试库"的版本么?我看公告上写着,2018-10-17就已经生效了啊,为什么会这样呢?

      2018-11-05
      回复
    • liya零夜
      liya零夜
      2018-11-05回复大叔·杨

      有些2.4.0发布的版本,生效的是文档和配置,2.4.0还没来呢

      2018-11-05
      回复
  • 万宝
    万宝
    2018-11-05

    同问,现在不是应该已经新版了吗?设置了navigateToMiniProgramAppIdList还要做关联?

    2018-11-05
    有用
    回复 2
    • 大叔·杨
      大叔·杨
      2018-11-05

      同样一头雾水~

      2018-11-05
      回复
    • liya零夜
      liya零夜
      2018-11-06回复大叔·杨

      新版本还没发布。。。现在是卡这个。

      2018-11-06
      回复
  • yyxx2z
    yyxx2z
    2018-11-03

    这是老版没有绑定小程序导致的,两个小程序之间要相互绑定

    2018-11-03
    有用
    回复 4
    • 大叔·杨
      大叔·杨
      2018-11-03

      老版本??那是需要升级基础库么?还请指条明路!

      2018-11-03
      回复
    • yyxx2z
      yyxx2z
      2018-11-03

      最新的小程序跳小程序规定

      老版的是要同一公众号下关联两个小程序,需要在该公众号 【微信公众平台】 网页下进行操作。

      2018-11-03
      回复
    • 大叔·杨
      大叔·杨
      2018-11-05回复yyxx2z

      声明上不是说,这个修改,已经在2018-10-17生效了啊~这似乎又有点儿矛盾?

      2018-11-05
      回复
    • yyxx2z
      yyxx2z
      2018-11-05回复大叔·杨

      是跳转询问弹窗17号开始生效  = 、 =

      2018-11-05
      回复
登录 后发表内容