收藏
回答

justify-content真机无效

框架类型 问题类型 API/组件名称 终端类型 微信版本 基础库版本
小程序 Bug justify-content 工具 6.6.7 2.3.0

- 当前 Bug 的表现(可附上截图)

    编辑器显示和真机样式不同,justify-content在真机上无效

----wxml


----wxss


----编辑器显示样式


----真机显示样式


----这是什么问题,求解

回答关注问题邀请回答
收藏

3 个回答

  • 社区技术运营专员-小柿子
    社区技术运营专员-小柿子
    2018-09-20

    你好,请提供一下出现问题的机型和微信版本,以及能复现问题的简单代码片段(https://developers.weixin.qq.com/miniprogram/dev/devtools/minicode.html)。

    2018-09-20
    有用
    回复 2
  • 繁花-崔弘亚
    繁花-崔弘亚
    2018-09-29

    space-evenly要的内核版本高啊……

    2018-09-29
    有用
    回复 2
    • null
      null
      2018-09-30

      请问内核是和手机相关还是和微信相关?

      2018-09-30
      回复
    • 繁花-崔弘亚
      繁花-崔弘亚
      2018-09-30回复null

      微信。之前有个帖子好像是说小程序这边Chromium 53? 我忘记具体的数字了。但是从caniuse这里可以看到,53不支持这个属性  https://caniuse.com/#search=space-evenly


      小程序这边没有提供自己的caniuse,

      TBS 4.2的话是57版本。

      可以看到只在grid上支持这个属性,flexbox不支持。

      2018-09-30
      回复
  • null
    null
    2018-09-20

    实测属性值=space-evenly无效。如果是flex-end是有效的,可以看出是部分属性值无效。但是问题还是没有解决,为什么无效呢?

    2018-09-20
    有用
    回复 2
    • .
      .
      2018-09-29

      我试了其它的 space-xx 的属性是有效的

      2018-09-29
      回复
    • null
      null
      2018-09-30回复.

      但是其他的属性值用处不大啊,还是想使用这个属性值

      2018-09-30
      回复
登录 后发表内容