收藏
回答

客户端版本太低,请更新到最新版本!

问题模块 框架类型 问题类型 操作系统 工具版本
开发者工具 小程序 Bug Windows 1.02.1902010

微信开发者工具版本号:1.02.1902010

小程序基础库版本号:2.6.0

微信版本号:7.0.3

都是最新的版本号但我wx.request请求还是报客户端版本太低,请更新到最新版本!

下面是我的代码:

wx.request({

url: 'http://api.bds35.cn/login?loginName=liuze&password=123456', // 仅为示例,并非真实的接口地址

method: 'POST',

header: {

'content-type': 'application/json' // 默认值

},

success(res) {

console.log(res.data)

}

})


最后一次编辑于  02-14  (未经腾讯允许,不得转载)
邀请回答
复制链接收藏投诉关注问题回答

3 个回答

  • 娇华
    娇华
    02-14

    麻烦给个相关的代码片段(https://developers.weixin.qq.com/miniprogram/dev/devtools/minicode.html)

    02-14
    赞同
    回复 3
  • 李亚川
    李亚川
    02-14

    这个错误是http://api.bds35.cn/login?loginName=liuze&password=123456返回的,并不是微信报错,你检查一下后端的代码。

    02-14
    赞同
    回复 1
    • .
      .
      02-15

      谢谢,已解决,听你们说是服务器端代码问题,我才想起来,需要跨域的!

      02-15
      回复
  • 吴奕群
    吴奕群
    02-14

    服务端代码问题吧

    02-14
    赞同
    回复