收藏
回答

小程序让老用户版本强制更新无效?

在程序app.js的show函数新增如下代码:

if (wx.canIUse('getUpdateManager')) {

const updateManager = wx.getUpdateManager();

updateManager.onCheckForUpdate(function (res) {

if (res.hasUpdate) { // 请求完新版本信息的回调

updateManager.onUpdateReady(function () {

wx.showModal({

title: '更新提示',

content: '新版本已经准备好,是否重启应用?',

success: function (res) {

if (res.confirm) {// 新的版本已经下载好,调用 applyUpdate 应用新版本并重启

updateManager.applyUpdate()

}

}

})

});

updateManager.onUpdateFailed(function () {

wx.showModal({// 新的版本下载失败

title: '已经有新版本了哟~',

content: '新版本已经上线啦~,请您删除当前小程序,重新搜索进入哟~',

})

})

}

})

} else {

console.log("getUpdateManager end")

wx.showModal({// 如果希望用户在最新版本的客户端上体验您的小程序,可以这样子提示

title: '提示',

content: '当前微信版本过低,无法使用该功能,请升级到最新微信版本后重试。'

})

}


但老用户访问还是不会提示更新版本。请大伙帮忙指点指点该如何解决。

回答关注问题邀请回答
收藏

1 个回答

  • 拾忆
    拾忆
    03-14

    在 onLaunch 里添加就行,然后添加那个代码后第一次发布上线的时候是不会有任何效果的,需要第二次再次发布上线才能看到效果,然后就可以了。

    03-14
    赞同
    回复 1
    • 阿棋
      阿棋
      03-14
      这边之前在onlauch里添加过不行,后面又改放到onshow里也还是无效。现在不知道该如何处理此问题。
      03-14
      回复
登录 后发表内容
问题标签