收藏
回答

微信小程序自定义底部菜单的神仙操作

问题模块 框架类型 问题类型 API/组件名称 终端类型 微信版本 基础库版本
API和组件 小程序 Bug 自定义底部菜单 客户端 7.0.3 2.6.4,2.6.2,2.4.4

微信自基础库 2.5.0 开始支持tabbar,使用方式是在app.json里声明custom为true.



然后出现一系列令人绝望的操作。


1,基础库2.5.0以下,比如2.4.4,不兼容自定义tabbar,原生的tabbar也没了。

最后测试是模拟器没了,真机没问题


2,基础库2.6.2,必报如下错误,编译十分卡顿

看起来好吓人啊


3,今天灰度了基础库2.6.4,错误倒是修了,但是点击切换tab仍旧会闪烁。闪烁这个东西在2.6.1出现,有段时间2.6.2修好了,但又引入另一个错,最终没修好,并且多了一个报错。

最后一次编辑于  03-27  (未经腾讯允许,不得转载)
邀请回答
复制链接收藏投诉关注问题回答

2 个回答

  • 娇华
    娇华
    03-25

    你好,这是个已知问题,下个基础库版本修复

    03-25
    赞同
    回复 5
    • 张明明
      张明明
      03-25

      低版本基础库tabbar消失那个问题呢?这个不解决就根本没法用啊,记得以前的兼容的,今天试就不兼容了。

      03-25
      回复
    • 娇华
      娇华
      03-25回复张明明

      这个需要开发者自己处理哈。基础库 2.5.0 开始支持,低版本需做兼容处理

      03-25
      回复
    • 张明明
      张明明
      03-25回复娇华

      哥,这个没法自己兼容。比如自定义顶部导航,不做兼容就会出现一个系统默认的,一个自己写的,这样低版本把自己写的隐藏掉就好了。而你这个是低版本的系统的也没了,自定义的也没了。能不能低版本的把系统导航放出来。

      03-25
      回复
    • 张明明
      张明明
      03-25回复娇华


      文档上的意思是官方做兼容,要求开发者tabbar配置需完整

      03-25
      回复
    • 贝贝
      贝贝
      04-23回复娇华

      帮忙看下,能否实现,不能的话,是否有计划解决


      https://developers.weixin.qq.com/community/develop/doc/000e86722146f0f92b78eaede51c00

      04-23
      回复
  • 爱会多美
    爱会多美
    03-27

    我已放弃官方tabbar包括他的自定义tabbar


    在页面加载自己的自定义tabbar组件,没有卡顿、闪烁。。。

    最爆的是可以完全自定义,可以做到任意页面显示或不显示(这个是官方tabbar的限制,显示tabbar的页面必须在json里写死)

    03-27
    赞同
    回复