收藏
回答

小程序对ios版本和微信版本有特殊要求么?

问题模块 框架类型 问题类型 操作系统 操作系统版本 手机型号 微信版本
客户端 小程序 Bug iOS 未知 ipX 6.5.3

老板去谈客户,客户使用的ipX,扫描小程序码进入小程序,发现数据都读不进来,技术人员真机测试和开发工具测试都没有问题,所以我怀疑可能是微信版本或者iOS版本影响了小程序的运行,有大佬给普及一下这方面的知识么!万分感谢!

上方的微信版本号是随便填的,,请勿当真

最后一次编辑于  2018-06-19  (未经腾讯允许,不得转载)
回答关注问题邀请回答
收藏

3 个回答

  • 社区技术运营专员-娇华
    社区技术运营专员-娇华
    2018-06-19

    你好,发帖的时候请如实填写信息哈


    使用真机测试也是使用iPhonex测试的吗?

    2018-06-19
    赞同
    回复 2
    •  
       
      2018-06-19

      客户的微信版本目前不了解,操作系统是ios11.4,基础库版本是1.9.8,机型是iPhone X

      2018-06-19
      回复
    • 社区技术运营专员-娇华
      社区技术运营专员-娇华
      2018-06-19回复 

      部分机型请求不到数据的问题大都是证书不支持导致的,你可以使用远程调试看下错误信息。

      再者:

       在正式版打开调试还有一种方法,就是先在开发版或体验版打开调试,再切到正式版就能看到vConsole。

      https://developers.weixin.qq.com/miniprogram/dev/api/setEnableDebug.html

      2018-06-19
      回复
  • Blues คิดถึง
    Blues คิดถึง
    2018-06-19

    会不会是新用户授权出现问题

    2018-06-19
    赞同
    回复 1
    •  
       
      2018-06-19

      首先是我们的小程序在未授权的情况下是不影响展示的,所以和授权的关系应该不大,不过我也对这方面进行了检查,没有太大的发现

      2018-06-19
      回复
  •  
     
    2018-06-19

    补充一下,客户的ios版本是11.4

    2018-06-19
    赞同
    回复