收藏
回答

async/await babel设置问题?

问题模块 框架类型 问题类型 操作系统 工具版本
开发者工具 小游戏 Bug macOS Wechat Lib:2.8.3, 2019.9.23 10:57:45

用async/await的时候总是出现这个错误,是哪儿的设置有问题吗?自己写的一个es6的库,用的是babel7,该用什么设置?


最后一次编辑于  09-26
回答关注问题邀请回答
收藏

2 个回答

  • 小游戏运营专员-宏
    小游戏运营专员-宏
    09-26

    您好,可参考一下此贴回复:小程序改造成async/await模式? - 微信开放社区 https://developers.weixin.qq.com/community/develop/doc/000cca349c400084c5e77058c5b404

    09-26
    赞同 1
    回复 1
    • dxd
      dxd
      09-26

      谢谢,看过了,没有什么帮助。我的babel设置:

      module.exports = {
        "presets": [
          [
            "@babel/preset-env"
          ]
        ],
        "plugins": [
          "@babel/plugin-proposal-class-properties",
          ["@babel/plugin-transform-runtime", {
            "corejs": 2,
          }]
        ]
      }


      完全搞不懂,以前完全没有任何问题,现在怎么各种冲突,郁闷

      09-26
      回复
  • 黄力钧
    黄力钧
    09-26

    从你的报错情况来看,是不是await获取的返回值不是一个promise对象导致的,你await拿到的返回值是一个promise对象吗?

    09-26
    赞同
    回复 2
    • dxd
      dxd
      09-27
      这个错误不是运行时的错误,是import时的错误。我写了一个加载云存储资源的库,希望能打包在各个项目中使用。我把这个库webpack + babel打包传到了npm上,然后在开发者工具中import这个库的时候就出现了这个错误,而实际上async/await的代码还没有开始执行。(在不知道哪个版本之前,这个库是毫无问题运行的,我使用过这个库在已发布的小游戏中,因此基本可以认为代码是没有问题的)。这次我升级了一些依赖的npm包,然后各种问题就出来了(构建库的时候没有任何问题)。
      09-27
      回复
    • 黄力钧
      黄力钧
      09-27回复dxd
      如果是升级了依赖包的问题,那你要看一下是升级了哪个依赖包导致出现的问题,然后再进一步缩小范围。
      09-27
      回复