收藏
回答

页面配置中的navigationStyle具体最低基础库是多少?

问题模块 框架类型 问题类型 终端类型 微信版本 基础库版本
框架 小程序 Bug 客户端 7.0.0 2.4.3

- 当前 Bug 的表现(可附上截图)


文档中写到微信客户端7.0.0,然后我按照客户端和基础库对应表,写的微信7.0.0基础库是2.5.2,但是我用开发工具模拟基础库的时候,基础库2.4.3就能实现页面自定义导航栏,而且navigationStyle不能动态配置,也就是说我配置了自定义导航栏,如果我兼容判断错误,就会导致显示异常。所以究竟是真机基础库2.4.3还是2.5.2?还是不判断基础库直接判断客户端版本?确定低于客户端7.0.0的不会自定义导航栏?


- 预期表现


开发者工具模拟基础库和文档保持一致



最后一次编辑于  03-26
回答关注问题邀请回答
收藏

2 个回答

  • Humi
    Humi
    06-11

    所以单个页面配置navigationStyle,楼主最后用的是2.4.3  还是 2.5.2 ?

    06-11
    赞同
    回复
  • 戴文亮
    戴文亮
    03-26

    文档中 7.0.0 指的是页面配置 navigationStyle 最低需要 7.0.0,全局配置是 6.6.0

    03-26
    赞同
    回复 3
    • __卧船画梅
      __卧船画梅
      03-26

      就是说的单个页面配置navigationStyle,但是微信客户端7.0.0版本对应的基础库是2.5.2,我用开发者工具模拟基础库2.4.3就可以实现页面配置导航栏。所以究竟是开发者工具的基础库模拟不对,还是说本来就是2.4.3基础库就可以实现?

      03-26
      回复
    • 戴文亮
      戴文亮
      03-26回复__卧船画梅

      请以真机为准

      03-26
      回复
    • 诗隐
      诗隐
      06-21回复戴文亮

      请问这个是模拟器的bug对吧?

      能否告知基础库对应的最低版本,用微信版本去判断总觉得有点虚…

      06-21
      回复