收藏
回答

用户的微信基础库版本跟开发者有关吗?

最近小游戏的后台错误有一些是微信6.6.x的版本报错的,根据排查可能跟微信基础库版本有关。想请问一下,我们小游戏重新编译、提交审核一次可以更新基础库版本吗?基础库版本是不是只跟用户的微信版本有关?然后,这个调试基础库的版本选择会影响到线上版本吗?

最后一次编辑于  02-27  (未经腾讯允许,不得转载)
邀请回答
复制链接收藏投诉关注问题回答

1 个回答

  • 拾忆
    拾忆
    02-27

    基础库是根据用户手机上微信的版本和更新有关,如果你的基础库版本太高,用户的太低就会有兼容问题,小程序后台可以设置用户最低基础库版本,低于设置的版本微信提示用户更新微信客户端。

    02-27
    赞同
    回复 2
    • 孤独的魂
      孤独的魂
      02-27

      我的基础库版本怎么设置啊,太高是怎么造成的,是微信开发者工具的版本吗?

      02-27
      回复
    • 拾忆
      拾忆
      02-27回复孤独的魂

      基础库太高的话部分新的API或者调整后的API在低版本是不兼容的~

      开发者工具中设置的是小程序能够正常开发和发布的基础库版本,但是用户的基础库版本是根据用户的微信版本和微信推送的为准,所以两个并不是一致的,小程序开发后台能强制设置当用户低于某个版本的时候不能访问,提示去升级微信客户端,仅此而已。

      02-27
      回复