收藏
回答

最新版的微信开发者工具有严重的bug

问题模块 框架类型 问题类型 操作系统 工具版本
开发者工具 小程序 Bug Windows v1.02.1808300

一个Page:

import Notify from '../../vant/notify/index'


json文件:

"usingComponents": {

"van-notify": "../../vant/notify/index",

}


微信开发者工具出现:

Component Please do not register multiple Pages的错误。程序无法通过编译。


然后我把该page的目录删除到回收站,然后又恢复回来,此时错误又自动消失了,真是变态。上一个版本的开发工具没有这个毛病。

请官方人员解决!


=======================

这个问题有时出现有时又不出现,没有做任何代码修改,只不过把引用组件的page先删除,开发工具自动刷新后,又马上恢复回来就解决了,所以应该是工具的bug。

最后一次编辑于  2018-09-05  (未经腾讯允许,不得转载)
回答关注问题邀请回答
收藏

3 个回答

  • 懿凡
    懿凡
    2018-11-19

    2018.06.12版本及之前没有这个问题,自从更新了版本就有这个multi page问题了!

    卸载重装2018.06.12版本就没有问题了。!!都不敢使用新版本,郁闷,微信一直没有解决这个问题!!

    2018-11-19
    赞同
    回复
  • dodomon
    dodomon
    2018-10-22

    这个问题现在还是没解决,只要更新了新版本都会。好郁闷。

    2018-10-22
    赞同
    回复
  • 龙哥呼弟
    龙哥呼弟
    2018-09-06

    同一个工具,同一个bug。我也是用这个组件的js都报这个错

    2018-09-06
    赞同
    回复