收藏
回答

【急急】安卓用户的小程序,在判断是否要升级小程序里,今天突报错,导致用户无法正常打开小程序

【急急急】今天在安卓手机上的小程序,在做版本检查是否要升级时updateManager.onUpdateReady,突报Cannot read property 'bind'导致全部无法使用。在苹果手机是正常的

代码:

问题应该是发生在:wx.getUpdateManager 的 onCheckForUpdate 或 onUpdateReady 里

手机真机调试报错截图:

最后一次编辑于  06-12
回答关注问题邀请回答
收藏

1 个回答

  • 黄正梦
    黄正梦
    06-12

    我也遇到了一样的问题

    一开始我这么写报错 后来我在里面加了一个 回调函数就不报错了

    updateManager.onCheckForUpdate()

    修改后不报错了

    updateManager.onCheckForUpdate(function (res) {})

    和基础库2.11.2有关 旧的基础库不会报错 新的基础库会报错

    06-12
    有用
    回复 7
    • 魁星
      魁星
      06-12
      问题是我已发布给客户在使用中,今天无故报错非常不应该呀,否则我要逐个客户又要发布更新。
      06-12
      回复
    • 黄正梦
      黄正梦
      06-12回复魁星
      2.11.2 还没有大规模推送 只有开发者能用 所以现在立马发一版 就算微信这个bug不修 问题也不大 
      关键是在考虑发版成本
      06-12
      回复
    • 魁星
      魁星
      06-12回复黄正梦
      不是,跟基础库应该没有关系,用去年发布的程序,今天打开发现都有这个问题。
      06-12
      回复
    • 黄正梦
      黄正梦
      06-12回复魁星
      我的就是基础库的问题 我用2.11.1之前的基础库就没有问题,用2.11.2就有问题
      06-12
      回复
    • 黄正梦
      黄正梦
      06-12回复魁星
      我有点开始相信你说的了 和基础库没关系了,我这里也开始了疯狂报错。
      06-12
      回复
    查看更多(2)
登录 后发表内容
问题标签