收藏
回答

npm 安装lodash报错

问题模块 框架类型 问题类型 API/组件名称 终端类型 操作系统 微信版本 基础库版本
API和组件 小程序 Bug npm 支持 微信iOS客户端 6.5.3 2.2.1

js文件和报错如图:
json文件如图:



安装了几个插件, 都会报错, 请问是为啥?


最后一次编辑于  2018-07-27
回答关注问题邀请回答
收藏

1 个回答

  • 小程序技术专员-june
    小程序技术专员-june
    2018-07-27

    lodash有动用到一些全局变量,这些变量在小程序的环境中会被注入成一个空对象,所以需要稍作修改才能使用。参考文档:https://developers.weixin.qq.com/miniprogram/dev/devtools/npm.html


    另外你提到安装其他插件也报错,可以检查下是否都是这个原因。如若不是,还请提供下包名我们看下是什么问题。

    2018-07-27
    赞同
    回复 2
    • 张鹏
      张鹏
      2018-07-30

      明白了, 谢谢啦

      2018-07-30
      回复
    • 장수연.(七七)
      장수연.(七七)
      03-18

      那想用lodash应该怎么办呢

      03-18
      回复