收藏
回答

picker日期选择器选择范围限制问题

框架类型 问题类型 API/组件名称 终端类型 微信版本 基础库版本
小程序 Bug picker 客户端 2.7.1 2.6.6

- 当前 Bug 的表现(可附上截图)

当一个页面同时出现2个或以上pickcer日期选择器的时候,范围限制在安卓中有问题,ios及微信开发者工具显示正常。

如设置start="1900-06-11",end="2019-05-10",

则在安卓中表现为(2019年的下一年是1900年):



- 预期表现

期望能与ios和开发者工具表现一致(2019年的下一年是2020年):



安卓跟ios表现的差异:

安卓中日历滚动到设置的end日期后,下一项是设置的start的日期(1900年),全部滚动项可选(因为都在可选范围内)。

ios中日历滚动到设置的end日期后,下一项还是正常的日历日期(2020年),并且设置的end后的日期(比如2020年)不可选。

回答关注问题邀请回答
收藏

2 个回答

  • 社区技术运营专员-灵芝
    社区技术运营专员-灵芝
    2019-06-21

    你好,请勿重复发帖,原帖正在确认问题,此重复帖隐藏,感谢配合

    2019-06-21
    赞同
    回复 1
    • 曲水
      曲水
      2019-06-21

      那请把原贴的《问题修复中》去掉,没去掉我还以为你们官方认为是同一问题,我才重新发帖的。

      2019-06-21
      回复
  • RuntimeException
    RuntimeException
    2019-06-21

    摆出来也不能选啊 老铁 想要一样的效果自己写

    2019-06-21
    赞同
    回复
登录 后发表内容