收藏
回答

今天下午4点多开始,app.json配置useExtendedLib,IOS就报错

框架类型 问题类型 终端类型 微信版本 基础库版本
小程序 Bug 微信iOS客户端 7.0.5 351

今天下午4点多开始,app.json配置useExtendedLib,IOS就报错。开发工具和安卓正常。(项目开发中突然开始报错,后来排查过程中发现,随便新建一个项目, 什么都不做,只要在app.json中添加了useExtendedLib配置,就报错)


{

  "pages":[

    "pages/index/index",

    "pages/logs/logs"

  ],

  "window":{

    "backgroundTextStyle":"light",

    "navigationBarBackgroundColor": "#fff",

    "navigationBarTitleText": "Weixin",

    "navigationBarTextStyle":"black"

  },

  "style": "v2",

  "sitemapLocation": "sitemap.json",

  "useExtendedLib": {

    "weui": true

  }

}


只要加了最后的,

"useExtendedLib": {

    "weui": true

  }

ISO打开,就报错。

回答关注问题邀请回答
收藏

5 个回答

  • 社区技术运营专员-Jahozheng
    社区技术运营专员-Jahozheng
    2020-12-24

    问题已修复,请知悉

    2020-12-24
    有用
    回复 4
  • 本本
    本本
    2020-12-23
    更进一步测试,更准确的说是配置weui报错,配置kbone没问题
    "useExtendedLib": {
        "weui": true
     } //有问题
    
    "useExtendedLib": {
        "kbone": true
     } //没问题
    


    2020-12-23
    有用 1
    回复 4
    • 张鑫
      张鑫
      2020-12-23
      我们这里也是 不过我们是安卓不行 应该是weui报错了
      2020-12-23
      回复
    • 本本
      本本
      2020-12-23
      我这面安卓是没问题的。可能和具体版本有关系,看样子还是npm靠谱,不然weui一更新,更新出BUG,我们未来也跟着受累
      2020-12-23
      回复
    • 张鑫
      张鑫
      2020-12-23回复本本
      官方也不知声呢 啥时候能好啊 太不靠谱了
      2020-12-23
      回复
    • 本本
      本本
      2020-12-24回复张鑫
      使用npm导入吧。具体步骤:
      1、在项目文件夹下 npm init
      2、下载 npm install weui-miniprogram
      3、在开发工具中的“工具”-“构建npm”
      4、在右上角详情中勾选“使用npm模块”
      5、在app.wxss中引入weui.wxss : @import '/miniprogram_npm/weui-miniprogram/weui-wxss/dist/style/weui.wxss'
      6、关闭开发工具,重启开发工具后,重新编译项目即可(这一点注意一下,我没起开发工具,样式错乱,重启之后再次编译就好了)
      2020-12-24
      回复
  • 王白
    王白
    2020-12-28

    赶紧修复啊!!!

    因为看中只需要基版2.2.1就能使用,所有才用的useExtendedLib来引入weui

    现在客户手机很多都用不了了,我们只能提醒客户升级微信版本。。。

    2020-12-28
    有用
    回复 1
    • 王白
      王白
      2020-12-28
      useExtendedLib 是不是应该支持下指定引入组件的版本号
      2020-12-28
      回复
  • FAIRY TAIL🤣
    FAIRY TAIL🤣
    2020-12-23

    2.11.2及以上是可以的。不过好像线上低版本现在会有问题,凉凉

    2020-12-23
    有用
    回复 1
    • 本本
      本本
      2020-12-24
      使用npm导入吧,保险,未来也没风险。
      1、在项目文件夹下 npm init
      2、下载 npm install weui-miniprogram
      3、在开发工具中的“工具”-“构建npm”
      4、在右上角详情中勾选“使用npm模块”
      5、在app.wxss中引入weui.wxss : @import '/miniprogram_npm/weui-miniprogram/weui-wxss/dist/style/weui.wxss'
      6、关闭开发工具,重启开发工具后,重新编译项目即可(这一点注意一下,我没起开发工具,样式错乱,重启之后再次编译就好了)
      2020-12-24
      回复
  • kit
    kit
    2020-12-23

    我也是这样

    2020-12-23
    有用
    回复 2
    • 本本
      本本
      2020-12-23
      上传体验版也一样还是出错。不知道正式版什么情况
      2020-12-23
      回复
    • 本本
      本本
      2020-12-24
      使用npm导入吧,保险,未来也没风险。
      1、在项目文件夹下 npm init
      2、下载 npm install weui-miniprogram
      3、在开发工具中的“工具”-“构建npm”
      4、在右上角详情中勾选“使用npm模块”
      5、在app.wxss中引入weui.wxss : @import '/miniprogram_npm/weui-miniprogram/weui-wxss/dist/style/weui.wxss'
      6、关闭开发工具,重启开发工具后,重新编译项目即可(这一点注意一下,我没起开发工具,样式错乱,重启之后再次编译就好了)
      2020-12-24
      回复
登录 后发表内容
问题标签