平台一个持续了半年未解决的BUG

问题模块 框架类型 问题类型 操作时间 AppID
管理后台 小程序 Bug 11-08 wxff700b5ccee3783a

- 当前 Bug 的表现(可附上截图)

设置体验版,在路径后面添加参数,提交,此时支持返回的图是正常的,关闭二维码弹层,重新点击体验版查看二维码,发现路径上带上了amp;,并且每刷新一次多一个amp;扫码后解析参数解析的也是带amp的


- 预期表现

刷新页面,点击体验版,路径正常

- 复现路径


- 提供一个最简复现 Demo

平台



此bug于4月份提过,目前该问题仍然存在,下方链接参考4月提的问题

[BUG] 平台体验版扫码设置参数后,刷新后参数自动添加amp

最后一次编辑于  星期四 17:52  (未经腾讯允许,不得转载)
收藏 0评论 0
关注问题写回答

14 个回答

  • LttLtt

    你好。能否提供下该页面入口在哪里?

    我们具体定位下。这边测试时是可以的

    赞同 0没有帮助
    评论 3
    复制
    置顶回答星期五 16:14
    • 土豆豆土豆豆

      按我的步骤:

      1. 打开开发平台,进入开发管理,选择下面的设置了体验版的开发版本,点击提交审核右面的箭头,选择【修改路径】

          

      2.路径后面添加参数?a=1&b=2如下图:


      3.点击提交,注意:此时出现的是正常的,不用管,关掉此弹窗,F5刷新页面(多刷新几次,连着刷新三四次),重新点击版本号下面的体验版。

      4.此时发现弹出来的体验版上的路径的参数被解析异常,如下图


      5.复现结束,额,我觉得按这个步骤,你完全可以必现的


      赞同 0没有帮助
      回复
      复制
      星期一 10:21
    • LttLtt
      回复土豆豆

      已修复,请重试看看

      赞同 0没有帮助
      回复
      复制
      星期一 15:46
    • 土豆豆土豆豆

      问题已确认修复,谢谢

      赞同 0没有帮助
      回复
      复制
      昨天 15:41
    评论
  • 土豆豆土豆豆

    重点在于刷新,一刷新页面后重新打开体验版的二维码弹层,路径的参数上就带上amp了

    赞同 4没有帮助
    评论 0
    复制
    星期四 17:53
  • 乐乐乐乐

    顶!

    赞同 2没有帮助
    评论 0
    复制
    星期四 18:03
  • ᕕ(ᐛ)ᕗᕕ(ᐛ)ᕗ

    顶!

    赞同 2没有帮助
    评论 0
    复制
    星期四 18:01
  • 喻

    顶!

    赞同 2没有帮助
    评论 0
    复制
    星期四 18:01
  • 时光。时光。

    顶!


    赞同 2没有帮助
    评论 0
    复制
    星期四 17:58
  • 衬衫衬衫

    +1

    赞同 2没有帮助
    评论 0
    复制
    星期四 17:57
  • 半夏半夏

    那分享到朋友圈中图片里的菊花二维码的参数sence用&隔开行不行?

    赞同 1没有帮助
    评论 0
    复制
    星期五 14:37
  • 码农界的贫农码农界的贫农

    赞同 1没有帮助
    评论 0
    复制
    星期五 11:54
  • 卢霄霄卢霄霄

    好可疑。。

    赞同 1没有帮助
    评论 5
    复制
    星期四 20:47
    • 土豆豆土豆豆

      嗯,有阴谋

      赞同 1没有帮助
      回复
      复制
      星期四 20:59
    • 卢霄霄卢霄霄
      回复土豆豆

      看起来应该是官方代码不小心写错了,总是把&转义成 & ,再来一次的时候,又把 &转移了,就变成了 &。。

      赞同 1没有帮助
      回复
      复制
      星期四 21:10
    • 土豆豆土豆豆
      回复卢霄霄

      有可能,半年了.... 等到1年的时候,我再发一次,BUG留存1周年纪念

      赞同 1没有帮助
      回复
      复制
      星期五 11:53
    • 展示更多
    评论