收藏
回答

根据官方的云开发兼容性设置,开发工具报错

问题模块 框架类型 问题类型 操作系统 工具版本
开发者工具 小程序 Bug Windows 1.02.1812260

根据文档介绍,可以在app.json中增加字段,对用户老版本微信进行兼容

然后我在app.json中增加了字段:

    },

    "cloud": true,

    "plugins": {

        "tencentvideo": {

            "version": "1.2.4",

            "provider": "wxa75efa648b60994b"

        }

    }

}



并且也在app.js中设置了初始化代码:

  onLaunch: function() {

    wx.cloud.init({

      traceUser: true,

      env: that.globalData.cloudID

    })

.......



但运行后,在windows和mac的开发工具都报错:

VM1307:1 [non-writable] modification of global variable "wx.cloud" is not allowed when using plugins at app.json.


还增加了Reporter.reportKeyValue的奇怪log


- 当前 Bug 的表现(可附上截图)



请教!

最后一次编辑于  2018-12-27
回答关注问题邀请回答
收藏

1 个回答

  • 互位®地图小程序工程师
    互位®地图小程序工程师
    2018-12-27

    在手机端(6.7.4测试版,安卓)预览版本时,可以正常使用云函数

    2018-12-27
    赞同
    回复