收藏
回答

button 的disabled样式不能改吗

问题模块 框架类型 问题类型 API/组件名称 终端类型 操作系统 微信版本 基础库版本
API和组件 小程序 Bug button 客户端 6.6.6 1.9.90

自己定义了button颜色,但是加了button[disabled]就会报错,怎么办


最后一次编辑于  2018-05-18  (未经腾讯允许,不得转载)
邀请回答
复制链接收藏投诉关注问题回答

1 个回答

  • 戴劼 DAI JIE
    戴劼 DAI JIE
    2018-05-18

    试了下,组件里确实有这个问题,和文档内所述一致:


    组件和引用组件的页面不能使用id选择器(#a)、属性选择器([a])和标签名选择器,请改用class选择器。

    只能通过定义外部样式类,或直接在 app.wxss 中定义绕过去。

    2018-05-18
    赞同
    回复 2
    • ༄风过无痕🐲
      ༄风过无痕🐲
      2018-05-18
      定义在app.wxss,无法作用在组件内部,引入样式带有id和属性选择器也会报错。只能加个disabled的类来覆盖了
      2018-05-18
      回复
    • 戴劼 DAI JIE
      戴劼 DAI JIE
      2018-05-18回复༄风过无痕🐲
      Component 构造时候有个属性:externalClasses 在外部可以作用到组件内部,测试可用。
      2018-05-18
      回复