收藏
回答

【functional-page-navigator组件】开发版无法正常使用

问题模块 框架类型 问题类型 API/组件名称 终端类型 操作系统 微信版本 基础库版本
API和组件 小程序 Bug functional-page-navigator 客户端 iOS 6.7.0 2.1.1

因为插件的开发版预览时,是一个特殊分配的小程序(即“插件开发助手”)来预览,在使用functional-page-navigator组件,version=“develop”时,弹窗提示“开发版小程序已过期”,导致无法调试。


此外由于我的插件还没有正式发布过,所以使用version=“release”也行不通。

最后一次编辑于  2018-06-25
回答关注问题邀请回答
收藏

3 个回答

  • 小程序技术专员-LastLeaf
    小程序技术专员-LastLeaf
    2018-06-25

    你好,如果有这样的提示,应当在这部手机上重新预览一下插件所有者小程序(插件所有者小程序应该在小程序开发模式下编辑和生成二维码)。

    2018-06-25
    赞同
    回复 14
    • 张博 Bill
      张博 Bill
      2018-06-25

      android 6.7.0(内测版),基础库2.1.1,使用

      functional-page-navigator

      组件时,报这个错

      2018-06-25
      回复
    • 小程序技术专员-LastLeaf
      小程序技术专员-LastLeaf
      2018-06-25

      正常情况下不应出现这个报错。请问,只有 android 的这个内测版有问题吗?

      2018-06-25
      回复
    • Fliwat
      Fliwat
      2018-07-03回复小程序技术专员-LastLeaf

      你好    ios下我也出现了同样的问题

      2018-07-03
      回复
    • 小程序技术专员-LastLeaf
      小程序技术专员-LastLeaf
      2018-07-03

      请问手机上的基础库版本是?

      2018-07-03
      回复
    • 狐狸♡恋人
      狐狸♡恋人
      2018-07-03回复小程序技术专员-LastLeaf

      你好.  我也报这个错 . 使用的 android ,  基础库版本是: 2.1.2 (2018.6.29 15:31:06)

      2018-07-03
      回复
    查看更多(9)
  • 胡撸胡撸瓢儿
    胡撸胡撸瓢儿
    2018-11-12

    楼主,请问这个报错问题解决了么?

    2018-11-12
    赞同
    回复 2
    • 张博 Bill
      张博 Bill
      2018-11-13

      我们现在没有使用这个能力,当时只是预研了一下。太长时间没弄了,不记得了,好像是没解决

      2018-11-13
      回复
    • 胡撸胡撸瓢儿
      胡撸胡撸瓢儿
      2018-11-13回复张博 Bill

      好的,谢谢

      2018-11-13
      回复
  • 笑叹、
    笑叹、
    2018-07-09

    你好 这个有找到是什么问题么  我也是这样

    2018-07-09
    赞同
    回复 4
登录 后发表内容