收藏
回答

IntersectionObserver基础库问题

问题模块 框架类型 问题类型 API/组件名称 终端类型 微信版本 基础库版本
API和组件 小程序 Bug IntersectionObserver 工具 7.0.7 2.7.1

IntersectionObserver的文档里说基础库1.9.3开始支持

但是在自定义组件中使用

this.createIntersectionObserver().relativeToViewport()

发现需要基础库2.7.1(不含)以上才有效



是工具有bug还是文档有问题还是我遗漏了啥

最后一次编辑于  09-28
回答关注问题邀请回答
收藏

1 个回答

  • 卢霄霄
    卢霄霄
    09-28

    以前按理说是这么用wx.createIntersectionObserver(this),不过你这里不显示应该是组件的逻辑改了的缘故,你在 ready生命周期里这么写就好了

    09-28
    赞同 2
    回复
问题标签