收藏
回答

基础库最低版本设置与实际体验不符

问题模块 框架类型 问题类型 操作系统 操作系统版本 手机型号 微信版本
客户端 小程序 Bug iOS ios12 iphone 6 6.7.3

基础库版本设置为2.3.0,用户微信为最新版本6.7.3,使用小程序的时候提示要更新微信,官方大大能不能帮忙看一下


最后一次编辑于  2018-11-16  (未经腾讯允许,不得转载)
回答关注问题邀请回答
收藏

1 个回答

  • 追梦的人(IT大叔一枚)
    追梦的人(IT大叔一枚)
    2018-11-16

    基础库是与微信版本分开的.你这情况估计是用户的基础库没有达到你的设置.

    2018-11-16
    赞同 1
    回复 7
    • 小师叔
      小师叔
      2018-11-16

      不应该是一个版本的微信对应一个版本的基础库嘛,而且用户已经是最新版本微信,他还怎么更新微信

      2018-11-16
      回复
    • 追梦的人(IT大叔一枚)
      追梦的人(IT大叔一枚)
      2018-11-16回复小师叔

      在新版本客户端发布后,再通过后台灰度新版本基础库,灰度时长一般为 12 ~ 24 小时,在灰度结束后,用户设备上才会有新版本的基础库。

      详细自己看...https://developers.weixin.qq.com/miniprogram/dev/framework/client-lib/

      2018-11-16
      1
      回复
    • 小师叔
      小师叔
      2018-11-16回复追梦的人(IT大叔一枚)

      这个对于我的情况还是不成立的

      第一,6.7.3这个版本发布已经很长时间了,远远超过24小时

      第二,我设置的基础库版本是2.3.0,也不是最新的基础库版本,按照对应的版本号来说微信版本6.7.2就可以支持


      2018-11-16
      回复
    • 追梦的人(IT大叔一枚)
      追梦的人(IT大叔一枚)
      2018-11-16回复小师叔

      你用户端的环境,是一个用户还是n多个用户?是ios还是Android..

      一般你这种情况,只要请用户过一会再进入你的小程序就可以了.

      2018-11-16
      1
      回复
    • 小师叔
      小师叔
      2018-11-16回复追梦的人(IT大叔一枚)

      暂时只接到一个用户的反馈,iOS 的。我目前是调低了基础库设置,怕就怕这种情况大规模出现

      2018-11-16
      回复
    查看更多(2)