收藏
回答

wx.setInnerAudioOption is not a function

问题模块 框架类型 问题类型 API/组件名称 终端类型 微信版本 基础库版本
API和组件 小程序 Bug innerAudioContext 客户端 6.6.6 6.6.7 6.7.1 2.0.0

错误信息:

wx.setInnerAudioOption is not a function. (In 'wx.setInnerAudioOption("obeyMuteSwitch",!1)', 'wx.setInnerAudioOption' is undefined);at ***** page lifeCycleMethod onLoad function


wx.setInnerAudioOption is not a function;at ***** page lifeCycleMethod onLoad function

Demo

/**

  * 页面的初始数据

  */

data: {

innerAudioContext: null,

},

/**

  * 生命周期函数--监听页面加载

  */

onLoad: function (options) {

var that = this;


//注册事件放在load中,注册一次即可。

that.data.innerAudioContext = wx.createInnerAudioContext();

that.data.innerAudioContext.volume = 0.3;

wx.setInnerAudioOption('obeyMuteSwitch', false);

that.data.innerAudioContext.onEnded(() => {

console.log('自然停止')


});

},


最后一次编辑于  2018-12-12  (未经腾讯允许,不得转载)
回答关注问题邀请回答
收藏

2 个回答

  • null
    null
    2018-12-12

    是不是基础库太低了

    2018-12-12
    赞同 1
    回复
  • 阿誉
    阿誉
    2018-12-12

    基础库需要2.3.0!

    2018-12-12
    赞同
    回复