收藏
回答

基础库2.8.3中,使用插件时,还是会提示全局变量不可重写的错误?

我在App.json中添加了微信智能对话的插件,然后就提示如下报错:


我查阅了相关的帖子,不是说2.6.3版本后已经开发了重写限制吗?

回答关注问题邀请回答
收藏

1 个回答

  • 社区技术运营专员-小柿子
    社区技术运营专员-小柿子
    2019-12-26

    切到新的基础库看下?

    2019-12-26
    赞同
    回复 3
    • Denson
      Denson
      2019-12-26
      最新的2.9.4依然会报错的。
      2019-12-26
      回复
    • 社区技术运营专员-小柿子
      社区技术运营专员-小柿子
      2019-12-27回复Denson
      麻烦提供能复现问题的代码片段https://developers.weixin.qq.com/miniprogram/dev/devtools/minicode.html
      2019-12-27
      回复
    • Denson
      Denson
      2019-12-27回复社区技术运营专员-小柿子
      问题好像定位到了:
      1. 我在代码片段中引入插件是不会报如问题图所示的错误。
      2.我在原代码中找到错误的”promise.prototype.finally"字段所在的位置是我从GitHub上引用构建出来的一个nmp工具包,源码可以看我附上的图片。这里是想定义一个方法。因为我自己写的小程序没有用到这个方法,所以即使出现报错我的小程序还是可以正常运行和渲染。我把该方法注释掉之后,就不会报错了。但这里我就不是很懂为什么人家定义的是一个方法,引用插件后会触发修改全局变量的报错?
      2019-12-27
      回复
登录 后发表内容
问题标签