收藏
回答

关于小程序api、组件等兼容性问题提一个建议

问题模块
API和组件

比如 xx在基础库版本 1.1.0 开始支持,低版本需做兼容处理


按照这样的做法,小程序总有一天会变成手机端的IE6,各种兼容,2

M的代码有几百kb是兼容代码,您觉得有必要吗?既然都是自家产品,能否直接搞成小程序底层热更新,每部手机只升级小程序模块,这样就不需要做兼容处理了,而且永远都是最新的。开发者也方便,您们维护也会很方便。希望能够考虑一下。

最后一次编辑于  2017-06-05  (未经腾讯允许,不得转载)
邀请回答
复制链接收藏投诉关注问题回答

5 个回答

  • maq
    maq
    2017-06-05

    凭个人感觉猜测,小程序的基础库应该已经是热更新的了,只不过这个更新会按照一个灰度策略来逐步推进,所以不能保证所有手机里都是“最新版”。


    如果是这样的话,我倒是建议官方能够及时发布灰度更新的进展情况,也让开发者能够心里有数,毕竟太早期的版本应该就不必考虑兼容了。

    2017-06-05
    赞同
    回复
  • Special
    Special
    2017-06-05

    @maq 文档即将更新这部分内容

    2017-06-05
    赞同
    回复
  • maq
    maq
    2017-06-05

    太好了!期待!

    2017-06-05
    赞同
    回复
  • Special
    Special
    2017-06-12

    https://mp.weixin.qq.com/debug/wxadoc/dev/framework/client-lib.html

    2017-06-12
    赞同
    回复
  • maq
    maq
    2017-06-12

    赞!先睹为快! ^_^

    2017-06-12
    赞同
    回复