收藏
回答

微信android6.5.7微信小程序基础库版本号获取为null的问题

问题模块
API和组件

经过反复试验,微信android6.5.7版本要支持微信小程序基础库版本号为1.1.0,需要重新卸载安装微信,然后打开小程序时系统会显示Toast为更新X5内核,更新完内核微信小程序就能识别到基础库版本号为1.1.0,但问题是,我们开发者不能要求我们小程序的用户去卸载微信重新安装,毕竟微信聊天记录,文件等卸载就没了(虽然有聊天记录可以备份恢复,但对用户来说,用个小程序还要做这么麻烦的事,兴趣就没了),希望官方能更新版本使用户使用小程序时如果没安装X5内核,提示安装,或者开放API,让开发在小程序中设置提醒!

最后一次编辑于  2017-04-18  (未经腾讯允许,不得转载)
回答关注问题邀请回答
收藏

3 个回答

  • 追梦的人(IT大叔一枚)
    追梦的人(IT大叔一枚)
    2017-04-20

    升级到微信最新版本后,重启一下就可以了.

    2017-04-20
    赞同
    回复
  • Keep Calm
    Keep Calm
    2017-04-19

    注销微信重新进入也不行啊,获取到的微信基础库版本号还是null

    2017-04-19
    赞同
    回复
  • 追梦的人(IT大叔一枚)
    追梦的人(IT大叔一枚)
    2017-04-19

    将微信注销,再进入就可以了.可以加个判断判断当前是否有加载基础库.没则提示.

    个人觉得目前基础库也是过渡,等升级到一定版本后,会驻留的.只是时间长度.

    2017-04-19
    赞同
    回复