收藏
回答

关联普通二维码 如果用户微信版本过低,有啥办法可以提示吗?

问题模块
API和组件

关联普通二维码 如果用户微信版本过低不支持小程序  就进不了小程序。

这时也没法提示用户升级,用户还以为这个二维码不对,很无奈。

最后一次编辑于  2017-11-29
回答关注问题邀请回答
收藏

7 个回答

  • 林超
    林超
    2017-11-29

    可以设置最低基础库版本


    参考


    https://kf.qq.com/touch/scene_faq.html?scene_id=kf4595


    2017-11-29
    赞同
    回复
  • 顾逸飞
    顾逸飞
    2017-11-29

    ios版 6.5.3  应该还不支持小程序?

    2017-11-29
    赞同
    回复
  • 仙森ღ₅₂₀¹³¹⁴
    仙森ღ₅₂₀¹³¹⁴
    2017-11-29

    - -没遇到过。。。。。啥版本 会这样提示那个字符串有图吗

    2017-11-29
    赞同
    回复
  • 顾逸飞
    顾逸飞
    2017-11-29

    压根进不了小程序啊  扫一扫得到的结果是一串字符

    2017-11-29
    赞同
    回复
  • 仙森ღ₅₂₀¹³¹⁴
    仙森ღ₅₂₀¹³¹⁴
    2017-11-29

    页面的app.js里做判断

    2017-11-29
    赞同
    回复
  • 仙森ღ₅₂₀¹³¹⁴
    仙森ღ₅₂₀¹³¹⁴
    2017-11-29
    wx.getSystemInfo({
      success: function(res) {    console.log(res.model)    console.log(res.pixelRatio)    console.log(res.windowWidth)    console.log(res.windowHeight)    console.log(res.language)    console.log(res.version)    console.log(res.platform)
      }
    })


    2017-11-29
    赞同
    回复
  • 仙森ღ₅₂₀¹³¹⁴
    仙森ღ₅₂₀¹³¹⁴
    2017-11-29

    在你的页面调用获取当前手机的信息Api 然后 判断版本。给他一个showModel提示 就可以了

    2017-11-29
    赞同
    回复