收藏
回答

wx.canIUse这API居然也有版本不兼容???

问题模块
API和组件

专门检查API是否兼容的 API,你这也来个不兼容?

还只是1.1.0这个版本不兼容???

小程序是不是缺人啊?



最后一次编辑于  2017-08-03  (未经腾讯允许,不得转载)
邀请回答
复制链接收藏关注问题回答

5 个回答

  • 李严习
    李严习
    2017-08-03

    你的这和官网上的使用方式一样吗?

    2017-08-03
    赞同
    回复
  • Zzero
    Zzero
    2017-08-03

    其他版本都没问题 就是1.1.0会报错

    2017-08-03
    赞同
    回复 2
    • 王江
      王江
      2018-07-18

      你后来怎么解决的啊,就是在公众号后天更改版本号就好了吗

      2018-07-18
      赞同
      回复
    • Zzero
      Zzero
      2018-07-19回复王江

      api更新后直接判断是否为true就行了啊

      if(wx.canIUse('request.object.method.GET')){

          console.log('兼容')

      }else{

          console.log('不兼容')

      }



      2018-07-19
      赞同
      回复
  • 王江
    王江
    2018-07-18

    我基础课改成2.2.0  也不行啊,使用方法一模一样,今天刚改的最低版本库

    2018-07-18
    赞同
    回复