收藏
回答

Expect END descriptor with depth 1

问题模块
API和组件

自定义组件使用报错未有wx-开头的命名文件夹或组件,前一秒正常,后一秒就报error

VM20195:2 Error: Expect END descriptor with depth 1 but get another

最后一次编辑于  2017-12-27  (未经腾讯允许,不得转载)
邀请回答
复制链接收藏投诉关注问题回答

10 个回答

  • LastLeaf
    LastLeaf
    2017-12-27

    你好,麻烦将基础库版本切换至 1.6.8 / 1.7.1 或更高,然后看看还有没有问题。

    2017-12-27
    赞同
    回复
  • 山竹
    山竹
    2017-12-27

    1.7.2没问题,在手机上预览也没问题,在编辑器上显示不出并报错

    2017-12-27
    赞同
    回复
  • LastLeaf
    LastLeaf
    2017-12-27

    在编辑器上显示不出并报错


    什么意思?

    2017-12-27
    赞同
    回复
  • 山竹
    山竹
    2017-12-27

    就是该组件在编辑器预览不显示,并报错。但在手机预览可以显示

    2017-12-27
    赞同
    回复
  • LastLeaf
    LastLeaf
    2017-12-27

    编辑器上选择的版本是?

    2017-12-27
    赞同
    回复
  • 山竹
    山竹
    2017-12-27

    1.7一下,偶发报错,

    2017-12-27
    赞同
    回复
  • LastLeaf
    LastLeaf
    2017-12-27

    应该是需要1.7.2以上的版本的。

    2017-12-27
    赞同
    回复
  • 小雨
    小雨
    2018-04-18

    目前我也出现这样的问题,请问这个错误是什么意思,该如何规避,小程序基础版本2.0@LastLeaf 官这个错误方

    2018-04-18
    赞同
    回复
  • LastLeaf
    LastLeaf
    2018-04-18

    目前确实还有一些情况可能会引发类似的问题,能否提供一个代码片段(https://developers.weixin.qq.com/miniprogram/dev/devtools/minicode.html)给我分析一下?

    2018-04-18
    赞同
    回复
  • 王珏
    王珏
    2018-07-30

    2018-7-10 微信开发者工具最新版,

    t同样遇到这个问题, 测试后发现是由组件引发的.,

    把组件上的wx:if  改成display:.... 莫名其妙就好了

    2018-07-30
    赞同
    回复