收藏
回答

wx.createSelectorQuery兼容问题

基础库1.4.2,微信版本也是最新版,模拟器正常打出,ios上用canIuse判断到是可以兼容,可却用不了、报错了,求解决方案,以下是截图:




回答关注问题邀请回答
收藏

13 个回答

  • 小程序技术专员-LastLeaf
    小程序技术专员-LastLeaf
    2017-08-24

    感谢反馈,我们查一下看看是什么原因。

    2017-08-24
    有用
    回复
  • 小程序技术专员-LastLeaf
    小程序技术专员-LastLeaf
    2017-08-21

    请问是iOS还是Android的微信呢?系统版本是?

    2017-08-21
    有用
    回复
  • 小程序技术专员-LastLeaf
    小程序技术专员-LastLeaf
    2017-07-20

    麻烦确认一下iphone上的版本信息,包括:


    1. 微信版本;

    2. 基础库版本(在vConsole的System栏下的WechatLib项)。

    2017-07-20
    有用
    回复
  • 小程序技术专员-LastLeaf
    小程序技术专员-LastLeaf
    2017-07-20

    P.S. 判的时候应该用 wx.canIUse('createSelectorQuery')

    2017-07-20
    有用
    回复
  • 小程序技术专员-LastLeaf
    小程序技术专员-LastLeaf
    2017-07-20

    你好,看log应该是走进了canIUse的false分支,也就是说基础库版本还不支持。麻烦看一下基础库版本号(在System栏下的WechatLib)。

    2017-07-20
    有用
    回复
  • 陈XI
    陈XI
    2017-08-24

    回12楼@LastLeaf

    我用豌豆荚下载了最新的版本更新了就可以了....   在微信上点击检查版本始终提示:已经是最新版本,android系统7.0版本,

    2017-08-24
    有用
    回复
  • 陈XI
    陈XI
    2017-08-19

    为毛我的微信版本也是6.5.8,lib是:1.2.5,然后我在微信的检查新版本里检查新版本想升级,告诉我是最新的版本?

    2017-08-19
    有用
    回复
  • Hao
    Hao
    2017-07-20

    嗯嗯,明白了,thanks

    不过这样挺麻烦的,因为不能确保用户的微信都是更新到最新版的,还要让用户去升级到最新版的微信

    2017-07-20
    有用
    回复
  • Hao
    Hao
    2017-07-20

    明白了,thx

    微信版本不是最新的,需要升级到最新版本基础库才是1.4的

    手机没推送更新。。。。

    2017-07-20
    有用
    回复
  • Hao
    Hao
    2017-07-20

    为何这里的WechatLib 是 1.2.5 ???

    2017-07-20
    有用
    回复

正在加载...

登录 后发表内容