收藏
回答

微信开发者工具不支持es6 do表达式吗?

问题模块
API和组件



看图,写上do表达式。开发工具会报错。官方大神回答下...

最后一次编辑于  2017-07-12  (未经腾讯允许,不得转载)
回答关注问题邀请回答
收藏

5 个回答

  • 晨
    2017-07-12

    es6中没有发现你所说的语法 https://github.com/lukehoban/es6features#readme

    2017-07-12
    赞同
    回复
  • spring
    spring
    2017-07-12

    恩恩!这可能就是答案了。

    2017-07-12
    赞同
    回复
  • 王宁宁
    王宁宁
    2017-07-12

    Hi,我推测是这样的:现在的ES6其实是从ECMA 2015以及之后版本的统称,你说的do表达式估计在ECMA 2015中不存在,而小程序的实现估计到ECMA 2015

    2017-07-12
    赞同
    回复
  • spring
    spring
    2017-07-12

    开启了一样报错,我只想测试下开发者工具支持不支持这do表达试.do表达式属于es6语法的不开启转是没问题的。

    2017-07-12
    赞同
    回复
  • 王宁宁
    王宁宁
    2017-07-12

    题主,你没有勾选开启ES6转ES5

    2017-07-12
    赞同
    回复