收藏
回答

关于TLS的和wx.request的一些问题

问题模块
API和组件

    在开发“微信小程序”的时候遇到如下错误:对应的服务器 TLS 为 TLS 1.0 ,小程序要求的 TLS 版本必须大于等于 1.2 。控制台输入 showRequestInfo() 可以获取更详细信息。上面说明了服务器的TLS版本必须大于1.2才能使用,我这里用的是TLS1.0。然后,有以下几点问题:

    1. 我在开发工具中,设置了“不校验安全域名、TLS版本以及HTTPS证书,在发布为”体验版“的时候可以成功在android上运行,但是在IOS上面还是报”发生SSL错误,无法建立与该服务器的安全连接“,这是否还是因为TLS版本问题导致。

    2. 在”体验版“上我可以关闭TLS版本的检测,那发布到了生产环境后,这个TLS版本检测是否是强制开启的?

最后一次编辑于  2017-12-13  (未经腾讯允许,不得转载)
邀请回答
复制链接收藏投诉关注问题回答

1 个回答

  • Link
    Link
    2017-12-16
    2017-12-16
    赞同
    回复