收藏
回答

2008R2 不支持 TLS1.2

问题模块
API和组件

对应的服务器 TLS 为 TLS 1.0 ,小程序要求的 TLS 版本必须大于等于 1.2 。控制台输入 showRequestInfo() 可以获取更详细信息。

微信小程序request的服务器是2008r2,应该支持TLS1.2,莫名报错误,和https生成的证书有关系吗,证书是用指令直接生成并安装在服务器上的

最后一次编辑于  2017-07-24  (未经腾讯允许,不得转载)
回答关注问题邀请回答
收藏

4 个回答

  • 〆偽,裝゛
    〆偽,裝゛
    2017-07-24

    你下面的评论没看.....  他的导入写法写错了...  我是手动一个个加的...  然后重启网站或iis 就行了

    2017-07-24
    赞同
    回复
  • 神祈鋒
    神祈鋒
    2017-07-24

    我试了1楼连接中其中一个方法:


    但还是没作用....还是一样的提示

    2017-07-24
    赞同
    回复
  • 影楼云选片 2019跨平台在线选片
    影楼云选片 2019跨平台在线选片
    2017-07-24

    楼上那个方法我也尝试过了,最后还是换成了2012R2才搞定。

    2017-07-24
    赞同
    回复
  • 〆偽,裝゛
    〆偽,裝゛
    2017-07-24

    https://segmentfault.com/a/1190000006781741#articleHeader3 按这个来,然后重启下网站

    2017-07-24
    赞同
    回复