收藏
回答

兼容性代码能否有个机制统一一个错误反馈?

问题模块
开发者工具

最近升级力度大,升级的API要做兼容性?有无反馈一个兼容性的测试报告 或者统一反馈一个错误事件提供告知用户版本问题呢?


最后一次编辑于  2017-11-15  (未经腾讯允许,不得转载)
回答关注问题邀请回答
收藏

2 个回答

  • 黄思程
    黄思程
    2017-11-15

    是遇到了什么问题

    2017-11-15
    赞同
    回复
  • 藤井树
    藤井树
    2017-11-15

    目前更新力度太快,很多API版本都担心有兼容性。每个api做兼容性写起来很别扭。但目前开发都是以最新版特性做开发,争取用到新的特性。兼容旧的微信版本,写起来代码维护力度比较多,穿插打补丁,目前只能这样先处理。内部没有这种机制,更新每一个客户端的版本同步。造成碎片化比较多,推的东西更新越快,兼容性的代码就要打很多。

    2017-11-15
    赞同
    回复