收藏
回答

小程序 warn __wxWebviewId__

问题模块
开发者工具

should not change the protected attribute __wxWebviewId__

小程序经常warn 这个提示,增加解决,有人解决过么?


最后一次编辑于  2017-07-26  (未经腾讯允许,不得转载)
邀请回答
复制链接收藏投诉关注问题回答

3 个回答

  • maq
    maq
    2017-07-26

    以前看到过别人出这个问题是因为在 app.js 里使用了 wx.navigateTo

    2017-07-26
    赞同
    回复
  • Andy
    Andy
    2017-07-26

    怎么解决这个问题啊,app.js 有页面跳转逻辑, 需要用wx.navigateTo

    2017-07-26
    赞同
    回复
  • maq
    maq
    2017-07-26

    那就是你程序逻辑的设计问题了,微信小程序的“首页”是在启动的时候由容器决定的,一般是 app.json 里面 pages 的第一个,这个“首页”不能由程序代码在运行时决定,所以,如果你要用 wx.navigateTo 的话也得到首页的 page 里面去做。

    2017-07-26
    赞同
    回复