收藏
回答

View 属性hidden控制显示与隐藏

<view hidden='{{hidden}}'>

     <view class='inputView'>

       <view>

         <text class='textTitle'>公司信息text>

       view>

       <text class='textValue'>{{companyInfo}}text>

     view>


     <view class='inputView'>

       <view>

         <text class='textTitle'>开户信息text>

       view>

       <text class='textValue'>{{bankInfo}}text>

     view>

   view>

hidden=false,这个布局模块不显示是什么问题造成的?

.inputView {

 display: flex;

 flex-direction: row;

 width: 100%;

 align-items: center;

 border-bottom: 1px solid #f0f0f0;

 margin-left: 10px;

 height: 50px;

}


回答关注问题邀请回答
收藏

4 个回答

  • Albert Einstein
    Albert Einstein
    2017-09-12

    请尝试

    vThat.setData({
      hidden: (options.hidden === 'false' ? false : true)
    })


    2017-09-12
    有用
    回复
  • Albert Einstein
    Albert Einstein
    2017-09-12

    是否可以提供相关代码示例呢

    2017-09-12
    有用
    回复
  • WesLon
    WesLon
    2017-09-12

     页面跳转传参:

    wx.navigateTo({

          url: '/pages/detailed/detailed?hidden=false',

        })


    detailed.js:

    Page({

    data: {

        hidden: false,

      },


      /**

       * 生命周期函数--监听页面加载

       */

      onLoad: function (options) {

        var vThat = this;

        vThat.setData({

          hidden: options.hidden

        });

      }

    })


    2017-09-12
    有用
    回复
  • 缪sy
    缪sy
    2017-09-12

    把你hidden的单引号 换成双引号试试

    2017-09-12
    有用
    回复
登录 后发表内容