收藏
回答

如何安装wx-server-sdk依赖??

开发文档中说:“云函数中使用 wx-server-sdk 需在对应云函数目录下安装 wx-server-sdk 依赖,在创建云函数时会在云函数目录下默认新建一个 package.json 并提示用户是否立即本地安装依赖。”但我在创建云函数时没有提示我安装wx-server-sdk 依赖,怎么办?

回答关注问题邀请回答
收藏

3 个回答

  • 社区技术运营专员-娇华
    社区技术运营专员-娇华
    2018-12-13

    试下这个?

    云开发,你想知道的都在这
    https://developers.weixin.qq.com/community/develop/doc/0000caa90a04785daf67c699f51801


    2018-12-13
    有用
    回复 1
    • Yu
      Yu
      2020-12-19
      没用,回答问题都不全面,极不友好,终端CMD完全无效
      2020-12-19
      回复
  • 小程序商城定制开发2600元全包
    小程序商城定制开发2600元全包
    06-08

    第一次上传部署云函数时,会提示安装依赖wx-server-sdk,这之前先安装node和npm。


    1. 安装node和npm

    https://nodejs.org/en/download/ 选择适合你操作系统的版本,下载 node.js,我的是Windows,然后双击安装,完成后,在cmd命令行窗口输入node -v和npm -v,如可打印版本号,则node和npm安装成功,如下图:



    2. 安装wx-server-sdk

    打开cmd命令行窗口(如果无法执行npm命令,请使用管理员打开cmd,谢谢 m0_46467015 的提醒) ,进入到云函数文件夹,然后执行:

    npm install --save wx-server-sdk@latest

    注意这里不能使用微信开发者工具的“在终端中打开”进入云函数文件夹,否则命令无效。


    等进度条走完后,在云函数文件夹里会多个package-lock.json文件,说明安装成功了。

    然后再重新上传并部署云函数,就可以啦。


    06-08
    有用 1
    回复
  • looptoto
    looptoto
    03-17

    Demo 中的调试 openid 时报的 要wx-server-sdk

    需要这个包的位置 WeChatProjects/miniprogram-1/cloudfunctions/login

    在终端中转到 这个目录后

    运行

    $ npm install request --save

    npm 下载完依赖包后 在资源管理器 login文件夹 右🐔 “上传并部署:所有文件

    就可以获取openid了

    CMD 无效的话 一个是有没有安装node, 安装后就可以用npm

    另一个就可能是路径了。

    Good Luck

    俺就想知道怎么上传文件不是图片 接着挖了


    03-17
    有用
    回复 1
登录 后发表内容