收藏
回答

小游戏getSystemInfoSync()获得的SDKVersion不正确

框架类型 问题类型 API/组件名称 终端类型 微信版本 基础库版本
小游戏 Bug getSystemInfoSync 工具 6.6.6 2.0.3

小游戏里很多api需要根据sdk的版本号来做适配,可是getSystemInfoSync()返回的SDKVersion似乎并不正确,如下图



望修正,或者该根据那个参数判断sdk的版本?谢谢

回答关注问题邀请回答
收藏

1 个回答

  • 小程序技术专员-june
    小程序技术专员-june
    2018-05-21

    这里通过SDKVersion字段获取版本号的方式是没错的,是这个版本的基础库有bug,导致返回了更旧的版本号。这个问题已经和相关开发同学沟通过,在后续的版本中应该会返回正确的版本号的。

    2018-05-21
    赞同
    回复 1
    • 刘昌涛
      刘昌涛
      2018-05-21
      明白了
      2018-05-21
      回复
登录 后发表内容