收藏
回答

请问如下问题是开发者工具的问题?还是?

昨天更新开发者工具到最新版本后,就一直报这个错,但也不影响项目调试,测试。

比较奇怪的是这个 at WebSocket._ws.onmessage

我运行别的不带websocket项目,也是提示这个报错。

后面是,所有项目都报这个错。。。。。。

如下所示:

VM2374:1

SystemError (appServiceSDKScriptError)

Cannot read property 'forceUpdate' of undefined

TypeError: Cannot read property 'forceUpdate' of undefined

at http://127.0.0.1:40842/appservice/__dev__/WAService.js:2:1338308

at http://127.0.0.1:40842/appservice/__dev__/WAService.js:2:648164

at o (http://127.0.0.1:40842/appservice/__dev__/asdebug.js:1:3197)

at e.exports.<anonymous> (http://127.0.0.1:40842/appservice/__dev__/asdebug.js:1:3577)

at http://127.0.0.1:40842/appservice/__dev__/asdebug.js:1:1844

at Array.forEach (<anonymous>)

at WebSocket._ws.onmessage (http://127.0.0.1:40842/appservice/__dev__/asdebug.js:1:1826)

回答关注问题邀请回答
收藏

5 个回答

  • Jation
    Jation
    07-03

    工具版本 号 和基础库版本号提供下?

    尝试切换基础库版本 能解决问题么?

    07-03
    有用
    回复 1
    • 杜雪
      杜雪
      07-05
      微信开发者工具 是最新版的。你说的基础库版号不知道从哪里查找。 目前,不知道是uni-app调用微信开发者工具的原因还是本身工具的原因。
      07-05
      回复
  • 社区技术运营专员-娇华
    社区技术运营专员-娇华
    06-29

    请具体描述问题出现的流程,并提供工具的版本号、能复现问题的简单代码片段https://developers.weixin.qq.com/miniprogram/dev/devtools/minicode.html

    06-29
    有用
    回复 9
    • 杜雪
      杜雪
      06-30
      抽空帮忙看看是不是工具的问题。因为不仅仅是我自己项目,其他人以前完好的项目也出错了,看回复。
      06-30
      回复
    • 社区技术运营专员-娇华
      社区技术运营专员-娇华
      06-30回复杜雪
      新建一个项目是否正常?
      06-30
      回复
    • 杜雪
      杜雪
      07-02回复社区技术运营专员-娇华
      新建小程序是正常的,但是用第三方编译项目调起开发者工具就会出现这个问题,可惜的是,想查看原因也没查看,只会提示已隐藏,下面也有一个兄弟也是如此。
      07-02
      回复
    • 陈亮
      陈亮
      07-05回复杜雪
      同问朋友是否解决?
      07-05
      回复
    • 杜雪
      杜雪
      07-05回复陈亮
      没,不知道是微信工具的原因还是uni-app的原因,但不影响功能使用,只是看着怪怪的。
      07-05
      回复
    查看更多(4)
  • 就是这样
    就是这样
    07-30

    未添加app_id问题,加了就好了

    07-30
    有用
    回复
  • Men.
    Men.
    07-02

    我也是啊 ,


    07-02
    有用
    回复 1
    • 杜雪
      杜雪
      07-05
      你找到原因了吗?
      07-05
      回复
  • 杜雪
    杜雪
    06-29

    这个是以前一直正常的一个项目,uni-app的colorui。

    复现路径:ext.dcloud.net 下载这个项目,编译运行到微信开发者工具。

    PS:没升级微信开发者工具前,我自己的项目和colorui都是零报错的。

    我debug的时候,是把整个页面恢复到空白,结果编译到微信开发者工具还是报这个错。

    很诡异了。代码片段没办法弄。不是我的问题。

    06-29
    有用
    回复 2
    • Jation
      Jation
      07-03
      基础库版本提供下 尝试切换基础库版本 能解决问题么?
      07-03
      回复
    • 惜
      09-09
      加上AppId就好了
      09-09
      回复
登录 后发表内容
问题标签