收藏
回答

wx.request不执行,这么诡异?

页面加载在onLoad和onShow里wx.request,sucess,fail,complete均不执行,相当于直接跳过wx.reuqest()。

太诡异了,为什么不行了?之前有人说是SSL证书的问题,我重新申请了个,还是不行。域名已经验证过了,域名之前也一直有用的另一个小程序,也正常。有没有人遇到过?

回答关注问题邀请回答
收藏

12 个回答

  • 黄晓依
    黄晓依
    01-12

    同样问题,请问楼主解决了吗

    01-12
    有用
    回复
  • 三宏
    三宏
    2020-11-26

    同样诡异的遇到了。无语了

    2020-11-26
    有用
    回复 2
    • 谢统华
      谢统华
      2020-11-28
      看淡官方的BUG,佛系的码农必须学会用自己的方式面对世事无常。
      2020-11-28
      回复
    • 三宏
      三宏
      2020-11-30回复谢统华
      他们最近太多bug了。工具打不开,闪退,请求不了各种作妖
      2020-11-30
      回复
  • 汪洋大海-黎
    汪洋大海-黎
    2020-11-01

    2020年11月1日了,还是没有解决,不过真机调试可以执行

    2020-11-01
    有用
    回复
  • koaxios
    koaxios
    2020-09-23

    对,我的是network里有response,但是就是执行不了success、fail、complete。定位

    上一周更新的。。。

    2020-09-23
    有用
    回复
  • 连胜
    连胜
    2020-09-15

    回退版本吧,我也遇到同样的问题,打印日志,发现根本没执行。开发者工具回退到6月份的版本,现在正常了。

    下载地址:https://developers.weixin.qq.com/community/develop/doc/000cccda3d45606c618a91a7b51001


    2020-09-15
    有用
    回复 1
    • 谢统华
      谢统华
      2020-09-23
      官方团队在作死吧,最近几个版本都很有问题。
      2020-09-23
      回复
  • 。
    2020-09-10

    昨天我也遇到了;只有路由跳转时onload会wx.request。把页面放在第一页就只执行onload不执行wx.request

    2020-09-10
    有用
    回复 2
    • 。
      2020-09-10
      楼主解决了没?
      2020-09-10
      回复
    • 谢统华
      谢统华
      2020-09-23
      没解决,只好搞了个缓冲页面。让用户手动点击进入页面,用bindtap触发执行wx.request
      2020-09-23
      回复
  • ForMMzzcc
    ForMMzzcc
    2020-09-08

    请问解决了吗,碰到了一样的问题,onload里面不执行,下断点看了一下,执行到URL后直接自动跳出,没有访问这个接口的记录

    2020-09-08
    有用
    回复 1
    • 谢统华
      谢统华
      2020-09-23
      没解决,还是存在这个问题。官方团队在开小差吧,大半个月了还没搞定。
      2020-09-23
      回复
  • 迷失的江山
    迷失的江山
    2020-09-07

    xhr里面看下有没有请求

    2020-09-07
    有用
    回复 5
    • 谢统华
      谢统华
      2020-09-07
      2020-09-07
      回复
    • 迷失的江山
      迷失的江山
      2020-09-07回复谢统华
      这就好奇怪 你单独写个demo试下 或者提交个代码片段我来帮你看下
      2020-09-07
      回复
    • 谢统华
      谢统华
      2020-09-07回复迷失的江山
      单独出来是可以运行的。在页面里就不行。
      2020-09-07
      回复
    • 迷失的江山
      迷失的江山
      2020-09-07回复谢统华
      这个还真没有遇见过  既然单独运行出来可以证明你这页面有问题  所有代码都注释了  单独请求这个接口看看
      2020-09-07
      回复
    • 谢统华
      谢统华
      2020-09-07
      现在就是只运行这个,其它的都没有运行的,因为刚启动小程序
      2020-09-07
      回复
  • 搞文艺的猿
    搞文艺的猿
    2020-09-07

    看下有没有请求

    2020-09-07
    有用
    回复 4
    • 谢统华
      谢统华
      2020-09-07
      没有访问链接记录。
      2020-09-07
      回复
    • 搞文艺的猿
      搞文艺的猿
      2020-09-07回复谢统华
      看下all里面,是不是跨域了
      2020-09-07
      回复
    • 谢统华
      谢统华
      2020-09-07
      我是老鸟了,之前开发的所有小程序,都用这个域名的。都没遇到这么诡异的事。就是小程序启动加载onload没有执行,但是启动后用其它事件来调用,就可以执行。
      2020-09-07
      回复
    • 搞文艺的猿
      搞文艺的猿
      2020-09-08回复谢统华
      神奇
      2020-09-08
      回复
  • 站住、举手
    站住、举手
    2020-09-07

    Network里有请求吗

    2020-09-07
    有用
    回复 1
    • 谢统华
      谢统华
      2020-09-07
      没有请求。直接跳过,不访问我的链接,我把链接故意改错,但又会报错,真诡异啊。
      2020-09-07
      回复

正在加载...

登录 后发表内容