收藏
回答

云函数本地安装依赖错误

框架类型 问题类型 终端类型 AppID 基础库版本
小程序 Bug 工具 wx0c0b59ce00cd25b6 2.3.0

正常流程:在云函数根目录上右键,在右键菜单中,可以选择创建一个新的 Node.js 云函数,将该云函数命名为 add。开发者工具在本地创建出云函数目录和入口 index.js 文件,同时在线上环境中创建出对应的云函数。创建成功后,工具会提示是否立即本地安装依赖,确定后工具会自动安装 wx-server-sdk

我的流程:工具会提示是否立即本地安装依赖,确定后弹出以下提示框



回答关注问题邀请回答
收藏

4 个回答

  • 邓坤力
    邓坤力
    2018-09-14

    请先安装 Node.js https://nodejs.org

    2018-09-14
    有用
    回复 4
  • 蔡於飞
    蔡於飞
    2018-09-18

    我加了系统环境变量,然后在IDE那边新建云函数时本地安装依赖,弹出的界面是这样的:


    在小程序里调用云函数,错误提示如下:


    2018-09-18
    有用
    回复
  • A   🍎兴盛果业🍎
    A 🍎兴盛果业🍎
    2018-09-16

    手动安装了Node.js,在windows下打开cmd,cd到你要建的云函数项目,输入 npm install 会下载一个库(node_modules),这样就ok了。但是开发工具里面 打开的cmd 不识别npm,windows下可以。以后的项目 都将库复制进去就ok了

    2018-09-16
    有用
    回复 4
  • 今晚,我要跟这世界说再见
    今晚,我要跟这世界说再见
    2018-09-16

    先在云开发->云函数->新增云函数,然后在小程序目录中同步云函数列表,一开始先不要在小程序目录里建



    2018-09-16
    有用
    回复
登录 后发表内容