收藏
回答

启用插件时,JavaScript内置对象中的方法不符合ECMAScript标准

框架类型 问题类型 终端类型 微信版本 基础库版本
小程序 Bug 工具 7.0.1 2.11.2

当添加插件后,微信小程序基础库会对JS引擎内置的一些对象启用保护,不允许用户定义脚本修改或删除内置对象方法。但这样的保护代码中有一些不符合ECMAScript语言环境规范之处:对一些内置的Function Object方法比如“Reflect.apply”、“Function.prototype.apply”等,返回的属性不是一个data property而是使用了getter/setter定义的accessor property,这导致了一些很流行的基础库无法正确被加载(比如npm上的util库、es-abstract库)。

相关Github Issue:https://github.com/ljharb/get-intrinsic/issues/5

其中库作者也同时是TC39成员的ljharb建议微信小程序基础库使用SES-shim(https://github.com/Agoric/SES-shim)库,而不是自己重新实现安全的运行环境。

最后一次编辑于  11-06
回答关注问题邀请回答
收藏
登录 后发表内容
问题标签