收藏
回答

小程序自定义组件渲染失败

问题模块
API和组件

最近我们开发小程序中,发现在真机上 ( iphone 6 plus, iOS 10.3.2 ) 手动切换 tab 一阵子后,页面中的自定义组件会无法渲染出来。

下面附上调试控制台打印的纪录,以及观察到渲染失败的节点。








从记录中可观察到页面似乎出现多个实例?会有多个onShow, onHide的呼叫。

出现这样的情况是否有可行的解决方案?


回答关注问题邀请回答
收藏

14 个回答

  • 小程序技术专员-LastLeaf
    小程序技术专员-LastLeaf
    2018-03-15

    那应该是其他的问题,麻烦另开新帖描述一下,把新帖地址贴在这帖下面。

    2018-03-15
    赞同
    回复
  • 小程序技术专员-LastLeaf
    小程序技术专员-LastLeaf
    2018-03-15

    这个问题是只有android出现的问题吗?

    2018-03-15
    赞同
    回复
  • 小程序技术专员-LastLeaf
    小程序技术专员-LastLeaf
    2018-03-09

    我们尝试在手机基础库版本 v1.9.93 中修复了这个问题的绝大多数情形。麻烦验证一下,谢谢!

    2018-03-09
    赞同
    回复
  • 小程序技术专员-LastLeaf
    小程序技术专员-LastLeaf
    2018-03-05

    预计这周内。到时候我再回个贴。


    出现这个问题的时候会导致全页渲染异常,应该是同一个问题的。

    2018-03-05
    赞同
    回复
  • 小程序技术专员-LastLeaf
    小程序技术专员-LastLeaf
    2018-03-05

    很快会上线修复。

    2018-03-05
    赞同
    回复
  • 小程序技术专员-LastLeaf
    小程序技术专员-LastLeaf
    2017-12-21

    感谢反馈。我们已经知道这个问题,会尽快修复。

    2017-12-21
    赞同
    回复
  • 小程序技术专员-LastLeaf
    小程序技术专员-LastLeaf
    2017-12-21

    你好,请问手机上的基础库版本是多少呢?(在system栏下WechatLib中可以看到)

    只有iOS会有问题吗?

    2017-12-21
    赞同
    回复
  • 米兰9号
    米兰9号
    2018-03-15

    https://developers.weixin.qq.com/blogdetail?action=get_post_info&lang=zh_CN&token=618047022&docid=000648dba984305d6476bae2a53c00


    这是新发的帖子

    暂时只在iOS 中碰到,Android没碰到

    2018-03-15
    赞同
    回复
  • 米兰9号
    米兰9号
    2018-03-15

    现在只在iOS上碰到了这个问题,android 我们还没测试,今天会测一下

    2018-03-15
    赞同
    回复
  • 米兰9号
    米兰9号
    2018-03-15

    @LastLeaf 经过测试,暂时没有复现组件崩溃的问题,但是出现了另外一个问题,tab页面会出白屏的情况。

    打开小程序后,如果未点击某一个tab页面,一直浏览其他页面,一段时间之后再点击该tab页面,就会出现页面完全空白的情况,甚至vConsole按钮也会消失,在其他页面正常显示。

    请测试一下这个问题。

    2018-03-15
    赞同
    回复

正在加载...

登录 后发表内容