收藏
回答

开发者工具出现渲染层错误,昨天都还好好的,今天一打开项目就报错,但是在真机上调试就没这个问题?

[渲染层错误] TypeError: Cannot read property 'replace' of undefined

    at rewritor (http://127.0.0.1:63695/__pageframe__/__extendedlib__/weui/latest/pageframe.js:176:44)

    at http://127.0.0.1:63695/__pageframe__/__extendedlib__/weui/latest/pageframe.js:194:127

[渲染层错误] webviewScriptError

Cannot read property 'replace' of undefined

TypeError: Cannot read property 'replace' of undefined

    at rewritor (http://127.0.0.1:63695/__pageframe__/__extendedlib__/weui/latest/pageframe.js:176:44)

    at http://127.0.0.1:63695/__pageframe__/__extendedlib__/weui/latest/pageframe.js:194:127

[渲染层错误] Uncaught

回答关注问题邀请回答
收藏

6 个回答

  • 社区技术运营专员-Jahozheng
    社区技术运营专员-Jahozheng
    2020-12-24

    问题已修复,请知悉

    2020-12-24
    有用
    回复 1
    • S
      S
      2020-12-24
      希望尽快解决,影响了我们很多用户
      2020-12-24
      回复
  • 微盟
    微盟
    2020-12-31

    要注意一下,使用WeUI ,新发版的小程序在微信7.0.11以下版本有报错,可能导致白屏。

    2020-12-31
    有用
    回复
  • Sorrow
    Sorrow
    2020-12-24

    基础库调到2.11.2 能解决~(又得临时发版本)

    2020-12-24
    有用
    回复 1
    • Jimmy L
      Jimmy L
      2020-12-24
      基础库不是你发版本决定的,开发工具里的基础库只对开发者有效。
      2020-12-24
      回复
  • 曲终人不散
    曲终人不散
    2020-12-24

    搞定了。看这个:

    https://developers.weixin.qq.com/community/minihome/doc/000e8e585500f8c32a7b7df605b800

    2020-12-24
    有用
    回复
  • 郭全祯℡¹⁷⁶³⁷⁸⁰¹⁸⁷⁰
    郭全祯℡¹⁷⁶³⁷⁸⁰¹⁸⁷⁰
    2020-12-23

    这怎么解决呢?

    官方不管么


    2020-12-23
    有用
    回复
  • FAIRY TAIL🤣
    FAIRY TAIL🤣
    2020-12-23

    weui出问题了,兄弟。听说线上都出问题了

    2020-12-23
    有用
    回复 1
    • FAIRY TAIL🤣
      FAIRY TAIL🤣
      2020-12-23
      2.11.1及以下均凉凉
      2020-12-23
      回复
登录 后发表内容
问题标签