收藏
回答

map组件同层渲染

问题模块 框架类型 问题类型 API/组件名称 终端类型 微信版本 基础库版本
API和组件 小程序 Bug map 微信安卓客户端 7.0.8 2.9.3

map组件同层渲染,在vivo u1机型下,渲染不出来。只显示了地图,没有显示另外一个元素内容。是不是因为机子太低端了,兼容问题?

最后一次编辑于  11-20
回答关注问题邀请回答
收藏

5 个回答

  • 社区技术运营专员-娇华
    社区技术运营专员-娇华
    11-20

    你好,麻烦具体描述问题流程,提供能复现问题的代码片段(https://developers.weixin.qq.com/miniprogram/dev/devtools/minicode.html;然后扫下面的小程序码,提供下页面截图

    11-20
    赞同
    回复
  • lgyg
    lgyg
    11-25

    我手机前面支持同层渲染。。今天修改功能发生真机突然就不支持了。。小米9我看新的运行基库是2.9.3是因为基库升级了?

    11-25
    赞同
    回复
  • .
    .
    11-20

    用cover-view不好吗?map不是层级最高吗?


    11-20
    赞同
    回复 1
    • MeCall小唐
      MeCall小唐
      11-20
      因为里面的功能比较复杂。我需要用touchmove控制这个层的滑动,里面还有动态加载数据。用cover-view做动画,手机上卡得莫法
      11-20
      回复
  • 肖宇
    肖宇
    11-20

    view 不能渲染要用cover-view

    11-20
    赞同
    回复 3
  • ʚ青哥ɞ
    ʚ青哥ɞ
    11-20

    基础库2.7.0起支持map同层渲染

    11-20
    赞同
    回复 5
    • MeCall小唐
      MeCall小唐
      11-20
      用的2.9.3
      11-20
      回复
    • ʚ青哥ɞ
      ʚ青哥ɞ
      11-20回复MeCall小唐
      另外一个元素时什么
      11-20
      回复
    • MeCall小唐
      MeCall小唐
      11-20回复ʚ青哥ɞ
      就一个view设置绝对定位,给z-index,我用米8还有苹果测试都可以渲染出来,换了一个低端机就出不来了
      11-20
      回复
    • ʚ青哥ɞ
      ʚ青哥ɞ
      11-20回复MeCall小唐
      试一下给map设置比这个低的z-index
      11-20
      回复
    • MeCall小唐
      MeCall小唐
      11-20回复ʚ青哥ɞ
      我给view设置z-index:100 ;map设置z-index:10;依然无效。我估计是机子太太低端了
      11-20
      回复
问题标签